• Forum
  • UNIX/Linux Programming

UNIX/Linux Programming

by admin
Welcome to this board!
Welcome to the forum for UNIX and Linux programmers in C++.com! In this forum, users can to talk about any topic related to programming in C++ for UNIX and Lin...
[no replies]
by colt
Not declared Xvlib function during building
[10 replies] Last: True. I have lived a simple life, not asking "Do we have X? If yes, th... (by keskiverto)
by colt
Relocation error against undefined symbol
Hi, When building a certain software, I receive this error message during the link stage: /usr/bin/ld: _obj/device/r4300/x86_64/dyna_start.o: relocation R_X...
[5 replies] Last: I think when "compiling" assembly (ASM) code, you cannot and don't nee... (by kigar64551)
by dkaip
Static Linux version of my program
A day before i send my Linux version of my program and it don't runs. If i want to send in many people, and all these people have no idea about functionals, th...
[3 replies] Last: The Flatpak and Snap are some sort of containers, aren't they? Yes. ... (by kigar64551)
Imho this is good, useful or suitable
I found that, imho this little Bash script is good, useful or suitable to compiling and building software https://github.com/abdulbadii/smart-directories-nav...
[2 replies] Last: Yet another set of synonyms to remember. (by kbw)
How to install clang 16.0 in ubuntu
Hi, I downloaded clang+llvm-16.0.0-x86_64-linux-gnu-ubuntu and extract all but how do I make clang and other binaries to be callable from any terminal? I ...
[1 reply] : If you just type the program name (e.g. "clang") without a full or r... (by kigar64551)
Does g++ support C++ 20 modules?
Hi, I have tried the following command line: Q:\c++\g++> g++ -std=c++20 -fmodules-ts -o main.exe main.cpp .\new_module.ixx Q:/msys64/mingw64/bin/....
[no replies]
by colt
Zsnes's zlib detection code problem.
Hi. I recently tried to build zsnes, however its zlib detection code seems to be seriously broken, as no matter how I pass it to configure, it won't detect it. ...
[4 replies] Last: Ok, I did the modifications suggested and the results were not very ex... (by colt)
Packaging your project
I'm using Makefile (Make) to package my SDL2 project. I'm also using SDL_GetPrefPath to locate and store/install my project's data, plugins, fonts, and other re...
[9 replies] Last: The method you're using to install the files is not the most efficient... (by maxim2511)
Detached thread error in helgrind
Hello everyone! I am implementing a detached thread using pthreads. After I run the code under helgrind, it reports a race condition and I think it might be ...
[7 replies] Last: If line 34 executes before line 12, then finished will never be set. ... (by kigar64551)
by t im
Can select use ET mode?
Several blogs tell me that only LT mode can be used in select while both LT and ET mode can be used in epoll. I wonder why ET mode cannot be used in select. ...
[2 replies] Last: Sorry for no references and thanks for your helpful reply. (by t im)
How to merge two partitions by using gdisk
How to merge two partitions, one is system, the lower offset, and the other destroyable content, the adjacent higher offset, by using gdisk (preferably if none ...
[3 replies] Last: Lets try analogous C++ case: char disk ; // The disk is an array of "... (by keskiverto)
How to Change ncurses window(pad) size?
Is there a way to change the maximum size of a window in ncurses ?
[3 replies] Last: Sorry been a little busy recently, but basically I meant a virtual win... (by highwayman)
Virtual memory assigned to my program
Hi everyone! I´ve got an application which periodically request for some GB of memory, and after some work is done, they are released. When I check the v...
[7 replies] Last: The application has been working for several days and the physical mem... (by Alejandro Antonio)
by t im
About pthread_detach()
I'm new to pthread and confused about the code below: #include <pthread.h> #include <iostream> #include <string.h> void* thr_fn1(void* arg) { printf...
[5 replies] Last: Thanks for all your answer. Get it. (by t im)
by helios
Detached threads
If main() returns while some threads are still running, what happens? Does the process simply end, killing those threads, or does it continue running until all ...
[9 replies] Last: The example on the cppref site is interesting. Thanks ++ (by Geckoo)
Need but failed run a user's alias inside bash CLI
Failed run a user's alias inside bash CLI How can run a user's alias $ grab 'man' but as to do it in a CLI $ bash -c "grab 'man'" bash: line 1...
[4 replies] Last: Presumbaly the OP has alias named "grab" that resolves to some existi... (by kbw)
Know a text editor have feature colorizing the loop?
Sorry if not really right place for this: Is there any S/W development text editor have feature colorizing every part that is of iteration or loop process ?
[5 replies] Last: Many modern IDEs have "folding" options and will show the beginning an... (by Duthomhas)
Cannot read data from file
Hello, I have developed an application that needs to read some data from file, but it seems to not work, here is my code: //this file exists, so no pr...
[3 replies] Last: if you want to open something only if it exists, there is a nocreate f... (by jonnin)
Excellent "Linux System Programming ... " Book
Following is an excellent Linux System Programming book that gives excellent C program examples and the book has excellent topics as chapter titles. https://ww...
[7 replies] Last: Thanks a bunch to all of you for the excellent help and information. B... (by AlexCantor)
  Archived months: [mar2024]